Back to overview
Degraded

Invaro Module Status: Verification

May 20, 2026 at 5:13am UTC
Affected services
Dashboard

Resolved
May 20, 2026 at 10:50pm UTC

We’re pleased to announce that the issue previously affecting some new users attempting to verify with Invaro has now been resolved. The Verification Module should now be functioning normally again for all users.

We sincerely appreciate everyone’s patience and understanding while this issue was being investigated and fixed. If you continue experiencing any verification-related issues, please report them to the team so they can be reviewed further.

Created
May 20, 2026 at 5:13am UTC

We are aware of an issue currently affecting some new users attempting to verify with Invaro. Our team has identified the problem, and the incident will be looked into as soon as the Chief Development Officer is available to investigate further. (This may mean Invaro's Verification Module may not work for new users trying to verify with Invaro for an estimated 7 days)

We appreciate your patience while we work toward resolving this issue. Additional updates will be provided if needed.